summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-06-26 10:24:14 +0300
committerTor Lillqvist <tml@collabora.com>2020-06-26 10:47:52 +0200
commit9ee0b88eb204a30e7dcb4591dcd900ecf4df3589 (patch)
treec432a129af253473fab904b8f31c72743b000b96 /configure.ac
parent658dbdaa5178012cd8bd54118026cca1b69159d6 (diff)
Introduce a --disable-gpgmepp option instead of the ad-hoc build_for_ios
Change-Id: I70ac1fe2f3a91e2fea39fc1a5133ee082f8055e1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/97197 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1b43e189bcb7..b03222285ccb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -686,7 +686,7 @@ darwin*) # macOS or iOS
AC_MSG_NOTICE([sanitized the PATH to $PATH])
fi
if test "$host_cpu" = "arm64" -o "$enable_ios_simulator" = "yes"; then
- build_for_ios=YES
+ enable_gpgmepp=no
_os=iOS
test_cups=no
enable_mpl_subset=yes
@@ -1765,6 +1765,11 @@ AC_ARG_WITH(system-poppler,
[Use system poppler (only needed for PDF import).]),,
[with_system_poppler="$with_system_libs"])
+libo_FUZZ_ARG_ENABLE(gpgmepp,
+ AS_HELP_STRING([--disable-gpgmepp],
+ [Disable building gpgmepp. Do not use in normal cases unless you want to fix potential problems it causes.])
+)
+
AC_ARG_WITH(system-gpgmepp,
AS_HELP_STRING([--with-system-gpgmepp],
[Use gpgmepp already on system]),,
@@ -4808,11 +4813,11 @@ if test "$cross_compiling" = "yes"; then
test $with_junit = no && sub_conf_opts="$sub_conf_opts --without-junit"
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
- test "$build_for_ios" = "YES" && sub_conf_opts="$sub_conf_opts build_for_ios=YES"
sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
# Don't bother having configure look for stuff not needed for the build platform anyway
./configure \
--disable-cups \
+ --disable-gpgmepp \
--disable-gstreamer-1-0 \
--disable-gtk3 \
--disable-pdfimport \
@@ -11355,9 +11360,9 @@ AC_SUBST(CLANG_CXXFLAGS_INTRINSICS_FMA)
SYSTEM_GPGMEPP=
-if test "$build_for_ios" = "YES"; then
- AC_MSG_CHECKING([whether gpgmepp should be disabled due to iOS])
- AC_MSG_RESULT([yes])
+if test "$enable_gpgmepp" = no; then
+ AC_MSG_CHECKING([whether to enable gpgmepp])
+ AC_MSG_RESULT([no])
elif test "$enable_mpl_subset" = "yes"; then
AC_MSG_CHECKING([whether gpgmepp should be disabled due to building just MPL])
AC_MSG_RESULT([yes])