summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbrainbreaker <gautamprajapati06@gmail.com>2017-06-02 22:01:25 +0530
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-06-03 23:01:13 +0200
commita21ec27fe5d8de3455522deeedc2dc43cb41c073 (patch)
tree5faf09ebe6f3636350d066ce9623c03d11371b30 /configure.ac
parenta318fc479cf7255a7fdf12f578b8c3199eda5367 (diff)
android: Update configure.ac for NDK r14b version
This commits updates the NDK version warning in confiure.ac for NDK r14b as it is now tested for building Android. Also, Modify code in JStatement.cxx to suppress the warning of ignoring return value which turns into error with --enable-werror argument. Change-Id: I40b264c2f39788948dbf947073de63c3347184f9 Reviewed-on: https://gerrit.libreoffice.org/38359 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d920cfaef5e3..24df1493171d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,11 +382,11 @@ if test -n "$with_android_ndk"; then
case $ANDROID_NDK_VERSION in
r9*|r10*)
;;
- 11.1.*|12.1.*|13.1.*)
+ 11.1.*|12.1.*|13.1.*|14.1.*)
;;
*)
- AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 13.1.* have been used successfully. Proceed at your own risk.])
- add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 13.1.* have been used successfully. Proceed at your own risk."
+ AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 14.1.* have been used successfully. Proceed at your own risk.])
+ add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 14.1.* have been used successfully. Proceed at your own risk."
;;
esac