summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-03-05 13:49:04 +0200
committerTor Lillqvist <tml@collabora.com>2014-03-05 16:13:45 +0200
commitc2756737e0dafe9c802346a2cf4d459bf59acd9d (patch)
tree64837ebbaac68579fd5815e9a9b6c3579d27259f /configure.ac
parent0b5558a68de6b9d887fd76a5ad8463116e7be4bd (diff)
Require Android API level 15, which is from December 2011
Note that this doesn't really mean a lot for the NDK. Change-Id: I4061cb856055ae126aadf56afc462182a875e65f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3676db5d0364..6742046b54d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -328,7 +328,7 @@ if test -n "$with_android_ndk"; then
android_gnu_prefix=i686-linux-android
fi
- test -z "$SYSBASE" && export SYSBASE=$ANDROID_NDK_HOME/platforms/android-9/arch-$android_cpu
+ test -z "$SYSBASE" && export SYSBASE=$ANDROID_NDK_HOME/platforms/android-15/arch-$android_cpu
test -z "$AR" && AR=$ANDROID_BINUTILS_BIN/$android_gnu_prefix-ar
test -z "$NM" && NM=$ANDROID_BINUTILS_BIN/$android_gnu_prefix-nm
test -z "$OBJDUMP" && OBJDUMP=$ANDROID_BINUTILS_BIN/$android_gnu_prefix-objdump
@@ -355,7 +355,7 @@ if test -n "$with_android_ndk"; then
fi
ANDROIDCFLAGS="$ANDROIDCFLAGS -ffunction-sections -fdata-sections"
ANDROIDCFLAGS="$ANDROIDCFLAGS -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR}libs/$ANDROID_APP_ABI"
- ANDROIDCFLAGS="$ANDROIDCFLAGS --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-$android_cpu"
+ ANDROIDCFLAGS="$ANDROIDCFLAGS --sysroot $ANDROID_NDK_HOME/platforms/android-15/arch-$android_cpu"
ANDROIDCFLAGS="$ANDROIDCFLAGS -Wl,--fix-cortex-a8"
if test -n "$ANDROID_USING_CLANG"; then
@@ -678,7 +678,7 @@ linux-android*)
fi
# Verify that the NDK and SDK options are proper
- if test ! -f "$ANDROID_NDK_HOME/platforms/android-9/arch-arm/usr/lib/libc.a"; then
+ if test ! -f "$ANDROID_NDK_HOME/platforms/android-15/arch-arm/usr/lib/libc.a"; then
AC_MSG_ERROR([the --with-android-ndk option does not point to an Android NDK])
fi