summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-11-27 21:27:28 +0100
committerAndras Timar <andras.timar@collabora.com>2014-12-13 16:00:47 +0100
commitca0c0663d11bcc58dca1cf23a08e97598c8948fa (patch)
tree7005d951758cc6f371af8bcd513b1e48684d52ae /configure.ac
parent2a684685313e5af85dd43ae0c00cc83a6995c627 (diff)
configure: do not default to system libjpeg on Linux
There are multiple different sonames of libjpeg in different distros, so use a system one only when system libs are requested. (cherry picked from commit 20d1e20d16ac377c160d47b53ff487a75fbd166f) Conflicts: configure.ac Change-Id: I164433a31ab0fb4723da6843eb1f1132c8447d9e Reviewed-on: https://gerrit.libreoffice.org/13157 Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 57606c094406..3429c0f902f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1560,7 +1560,7 @@ AC_ARG_WITH(system-zlib,
AC_ARG_WITH(system-jpeg,
AS_HELP_STRING([--with-system-jpeg],
[Use jpeg already on system.]),,
- [with_system_jpeg=auto])
+ [with_system_jpeg="$with_system_libs"])
AC_ARG_WITH(system-libgltf,
AS_HELP_STRING([--with-system-libgltf],
@@ -7664,18 +7664,6 @@ AC_SUBST(SYSTEM_ZLIB)
dnl ===================================================================
dnl Check for system jpeg
dnl ===================================================================
-AC_MSG_CHECKING([which jpeg to use])
-if test "$with_system_jpeg" = "auto"; then
- case "$_os" in
- WINNT|Darwin|iOS|Android)
- with_system_jpeg="$with_system_libs"
- ;;
- *)
- with_system_jpeg=yes
- ;;
- esac
-fi
-
if test "$with_system_jpeg" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_JPEG=TRUE