summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-08-08 14:58:08 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2014-08-25 15:17:51 -0500
commitf83c7358964cf9f265f21e7dfa72e82a26923b3e (patch)
treeda91d9965ed50b00d1714f52009a3c6ee32a8279 /configure.ac
parente10e1b06cbbf337e8277063651b6e48011df5fd4 (diff)
fdo#82430: configure: MSVC build: avoid using SSE2 instructions
MSVC 2012 for x86 defaults to -arch:SSE2; binaries do not run on any AMD 32-bit CPU, neither on Intel Pentium III. http://msdn.microsoft.com/en-us/library/vstudio/7t5yh4fd%28v=vs.110%29.aspx (cherry picked from commit 8bd6bf93b7711a7ac7c5cbd7c3bb980481570ebd) fdo#82430: MSVC 2010 refuses both -clr and -arch in the same command (cherry picked from commit 36ce22f41a754fa405804434899a08a23081e721) fdo#82430: gcc-wrappers: don't stop if REAL_CXX_FLAGS is empty Hopefully should fix MSVC 2010 build... (cherry picked from commit a18ff3d5c75c2b468c48bd19439dee0689d24d67) Change-Id: Ie8253137db2699f2a7fa69c4ac4e7ded90931e3e Reviewed-on: https://gerrit.libreoffice.org/10925 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> Tested-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 809b353447c0..02791cab2fc9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3775,6 +3775,9 @@ if test "$_os" = "WINNT"; then
COMPATH=`echo $VC_PRODUCT_DIR`
fi
fi
+ if test "$BITNESS_OVERRIDE" = "" -a "$vcnum" != "100"; then
+ CC="$CC -arch:SSE" # MSVC 2012 default for x86 is -arch:SSE2
+ fi
export INCLUDE=`cygpath -d "$COMPATH/Include"`
PathFormat "$COMPATH"