summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaled@libreoffice.org>2023-06-21 13:26:35 +0300
committerخالد حسني <khaled@libreoffice.org>2023-06-21 16:59:39 +0200
commit40e43ae633e00811236ce09710b52062789236ab (patch)
tree3fc65fd56c535eb0c88b52e7d59fc271e938d337 /configure.ac
parentc276694bc06ae460a78532757db08e531b478e20 (diff)
No need to fiddle with ICU UChar typedef anymore
The affected external dependencies should be building with c++11 by now already. Change-Id: I0d1f8aed6ed28f510f456a368b724c3c4eeb3240 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/153389 Tested-by: Jenkins Reviewed-by: خالد حسني <khaled@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index a494a2bd9515..cd5338c42dd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10779,18 +10779,11 @@ if test "$SYSTEM_ICU" = TRUE; then
fi
fi
-# As of ICU 59 it defaults to typedef char16_t UChar; which is available
-# with -std=c++11 but not all external libraries can be built with that,
-# for those use a bit-compatible typedef uint16_t UChar; see
-# icu/source/common/unicode/umachine.h
-ICU_UCHAR_TYPE="-DUCHAR_TYPE=uint16_t"
-
AC_SUBST(SYSTEM_GENBRK)
AC_SUBST(SYSTEM_GENCCODE)
AC_SUBST(SYSTEM_GENCMN)
AC_SUBST(ICU_MAJOR)
AC_SUBST(ICU_MINOR)
-AC_SUBST(ICU_UCHAR_TYPE)
dnl ==================================================================
dnl Breakpad