summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-23 18:49:16 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-23 18:50:50 +0200
commit43fe205a77f8e9f0bd36dc25dd14eaf433488621 (patch)
tree6b3aab794abbc7e403038a80feadd97e47e252ff /configure.ac
parent0ed451e338d2c211acf5b311860c468e335d6d31 (diff)
Don't turn on DISABLE_EXPORT automatically for Android and iOS
Eventually we want to be able to save documents, too. Change-Id: Ib971163163f78d304deaac2d87db40c8438a34e9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index ebb26a862ee8..6a31c894d767 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2103,20 +2103,8 @@ if test $_os != iOS -a $_os != Android; then
BUILD_TYPE="$BUILD_TYPE DESKTOP"
fi
-# Currently we build only viewer apps for Android (and for iOS not even that yet), so to avoid getting
-# some pathological export-related code and data linked in, we will add some judicious #ifndef
-# DISABLE_EXPORT in the code in places where the linker map shows it has a big impact. Places that
-# generate large amounts of code or data related to export only but still gets linked in. At least
-# that is the theory, let's see...
-
-if test -z "$enable_export"; then
- if test $_os != Android -a $_os != iOS; then
- enable_export=yes
- fi
-fi
-
DISABLE_EXPORT=''
-if test "$enable_export" = yes; then
+if test "$enable_export" != no; then
BUILD_TYPE="$BUILD_TYPE EXPORT"
else
DISABLE_EXPORT='TRUE'