summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Gomez <agomez@igalia.com>2013-04-11 10:32:54 +0300
committerDavid Tardon <dtardon@redhat.com>2013-04-13 10:49:46 +0000
commit48d49759a4d43b5e5dd997b4a87555ce25ae2a04 (patch)
tree738b34263b3c6c71a9cff99b60035b46dbf4a07d /configure.ac
parentf3f9db6d1d1fe63a4323f43de91a13aae03b1228 (diff)
neon: honor --disable-openssl and use GNUTLS
On --disable-openssl, the bundled neon library will link against GNUTLS + gcrypt instead of OpenSSL. Change-Id: I5b3f09cd1003aefde0478aaab026536c962212c4 Reviewed-on: https://gerrit.libreoffice.org/3330 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 75e149f923fd..da58c8969fe5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8580,6 +8580,21 @@ fi
AC_SUBST([DISABLE_OPENSSL])
dnl ===================================================================
+dnl Check for building gnutls
+dnl ===================================================================
+AC_MSG_CHECKING([whether to use gnutls])
+if test "$enable_neon" != "no" && test "$enable_openssl" = "no"; then
+ AC_MSG_RESULT([yes])
+ AM_PATH_LIBGCRYPT()
+ PKG_CHECK_MODULES(GNUTLS, [gnutls],,
+ AC_MSG_ERROR([Disabling OpenSSL was requested, but GNUTLS is not
+ available in the system to use as replacement.]))
+fi
+
+AC_SUBST([LIBGCRYPT_CFLAGS])
+AC_SUBST([LIBGCRYPT_LIBS])
+
+dnl ===================================================================
dnl Check for system redland
dnl ===================================================================
dnl versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)