summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2023-11-10 18:17:18 +0100
committerMike Kaganski <mike.kaganski@collabora.com>2023-11-10 21:37:10 +0100
commit9aa2eee9d88df6f68befd4758bc5af847d07c805 (patch)
tree49f17a3b582023eb0ddb17e28027eb1cd40d659e /configure.ac
parent630ea24fa493be653686689b63692c104f2b0ae5 (diff)
Fix the fix
Commit 87f0da8023081398d72372367db11d4a97d91833 put the check into a wrong position Change-Id: I459c11e00babfc604c5d35aac4f7cd0ce3701c3d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/159237 Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7ec877ed5a78..545c3de33303 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13581,9 +13581,6 @@ UPDATE_CONFIG=
if test "$enable_online_update" = ""; then
AC_MSG_RESULT([no])
else
- if test "$enable_curl" != "yes"; then
- AC_MSG_ERROR([--disable-online-update must be used when --disable-curl is used])
- fi
if test "$enable_online_update" = "mar"; then
AC_MSG_RESULT([yes - MAR-based online update])
ENABLE_ONLINE_UPDATE_MAR="TRUE"
@@ -13593,6 +13590,9 @@ else
UPDATE_CONFIG="$with_update_config"
AC_DEFINE(HAVE_FEATURE_UPDATE_MAR)
elif test "$enable_online_update" = "yes"; then
+ if test "$enable_curl" != "yes"; then
+ AC_MSG_ERROR([--disable-online-update must be used when --disable-curl is used])
+ fi
AC_MSG_RESULT([yes])
ENABLE_ONLINE_UPDATE="TRUE"
else