summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2013-04-07 12:14:36 -0400
committerPeter Foley <pefoley2@verizon.net>2013-04-07 12:14:36 -0400
commitb97cade9183d14ad21ae71892348a9a81689488b (patch)
treeaf4175b2d3b2937016a74e3e81590e644fc565e2 /configure.ac
parente1248e0f0dcf427b4e8b8615d08524e6f3c4cc77 (diff)
Supress warnings about unset classpath
I get the below warning for every single jar file without this patch. warning: [options] bootstrap class path not set in conjunction with -source 1.5 1 warning Change-Id: I71c01aeea993640f1ec86fe1d8a977656861358d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 912c111b3fbe..cdda016df724 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6068,6 +6068,10 @@ you must use the "--with-jdk-home" configure option explicitly])
if test "$_jdk_ver" -lt 10500; then
AC_MSG_ERROR([JDK is too old, you need at least 1.5])
fi
+ if test "$_jdk_ver" -gt 10600; then
+ JAVA_CLASSPATH_NOT_SET="1"
+ fi
+
AC_MSG_RESULT([checked (JDK $_jdk)])
JAVA_HOME=`echo $JAVAINTERPRETER | $SED -n "s,//*bin//*java,,p"`
if test "$_os" = "WINNT"; then
@@ -6613,6 +6617,7 @@ AC_SUBST(JAVACOMPILER)
AC_SUBST(JAVADOC)
AC_SUBST(JAVAINTERPRETER)
AC_SUBST(JAVAIFLAGS)
+AC_SUBST(JAVA_CLASSPATH_NOT_SET)
AC_SUBST(JAVA_HOME)
AC_SUBST(JAVA_SOURCE_VER)
AC_SUBST(JAVA_TARGET_VER)