summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-04-03 17:13:32 +0200
committerFridrich Strba <fridrich@documentfoundation.org>2013-04-05 23:33:29 +0000
commitbba6e9ebeb67235ee77e723af354474d5a3e9b85 (patch)
tree0873e4a3d3cbec2b6493c1a82080cb698fd36837 /configure.ac
parent221cd46f47f40c892e554b0848978bda3d9957e1 (diff)
allow Package to install to other dir than $OUTDIR
This is preparatory work for creating installation directly by gbuild. Change-Id: I1b11db37c76ff781731845650169f39cb78fe820 Reviewed-on: https://gerrit.libreoffice.org/3189 Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org> Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c460f735590c..912c111b3fbe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3896,11 +3896,14 @@ if test -n "${with_solver_and_workdir_root}"; then
# IsValidFilePath in /sal/osl/w32/file_url.cxx rejects "X:\\" breaking idlc
if echo ${formatted_path} | $GREP -q '/$'; then
WORKDIR=${formatted_path}workdir/${INPATH}
+ INSTDIR=${formatted_path}instdir/${INPATH}
else
WORKDIR=${formatted_path}/workdir/${INPATH}
+ INSTDIR=${formatted_path}/instdir/${INPATH}
fi
else
WORKDIR=${BUILDDIR}/workdir/${INPATH}
+ INSTDIR=${BUILDDIR}/instdir/${INPATH}
fi
OUTDIR="${SOLARVER}/${INPATH}"
SOLARINC="-I. -I${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc -I$SRC_ROOT/solenv/inc $SOLARINC"
@@ -3913,6 +3916,7 @@ AC_SUBST(EPM_FLAGS)
AC_SUBST(GUI)
AC_SUBST(GUIBASE)
AC_SUBST(INPATH)
+AC_SUBST([INSTDIR])
AC_SUBST(OS)
AC_SUBST(OUTDIR)
AC_SUBST(OUTPATH)