summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <tbehrens@suse.com>2013-04-03 12:48:54 +0200
committerThorsten Behrens <tbehrens@suse.com>2013-04-03 12:48:54 +0200
commitbe21cd2bd2f0eeed4ab0fb600dd75f10a0593c23 (patch)
tree4026c0408c8cb8bfa5418b46b668ef12706f63a9 /configure.ac
parent47664d3f2e12649d324b031ca6ffd5589fe3d197 (diff)
Be more serious with our 10.6 baseline on OSX
Change-Id: Ic9e2970a29e387dc85972dc97a66e1dc47913a05
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 25 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 1f4e2b11439c..f096cb36470e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1930,7 +1930,7 @@ AC_ARG_WITH(macosx-sdk,
[
Usage: --with-macosx-sdk=<version>
- e. g.: --with-macosx-sdk=10.4
+ e. g.: --with-macosx-sdk=10.6
there are 3 options to control the MacOSX build:
--with-macosx-sdk (refered as 'sdk' below)
@@ -1945,10 +1945,10 @@ AC_ARG_WITH(macosx-sdk,
command line || config result
==========================================
min | max | sdk || min | max | sdk |
- ? | ? | ? || 10.4 | 10.s | 10.s |
- ? | ? | 10.x || 10.4 | 10.x | 10.x |
- ? | 10.x | ? || 10.4 | 10.s | 10.s |
- ? | 10.x | 10.y || 10.4 | 10.x | 10.y |
+ ? | ? | ? || 10.6 | 10.s | 10.s |
+ ? | ? | 10.x || 10.6 | 10.x | 10.x |
+ ? | 10.x | ? || 10.6 | 10.s | 10.s |
+ ? | 10.x | 10.y || 10.6 | 10.x | 10.y |
10.x | ? | ? || 10.x | 10.s | 10.s |
10.x | ? | 10.y || 10.x | 10.y | 10.y |
10.x | 10.y | ? || 10.x | 10.y | 10.y |
@@ -1975,7 +1975,7 @@ AC_ARG_WITH(macosx-version-min-required,
[
Usage: --with-macosx-version-min-required=<version>
- e. g.: --with-macos-version-min-required=10.4
+ e. g.: --with-macos-version-min-required=10.6
see --with-macosx-sdk for more info
],
,)
@@ -2363,12 +2363,9 @@ if test "$_os" = "Darwin"; then
BITNESS_OVERRIDE=64
fi
- # If no --with-macosx-sdk option is given, first look for the 10.4u
- # SDK (which is distributed with the obsolete Xcode 3), then the
- # 10.6, 10.7 and 10.8 SDKs, in that order. (Don't bother looking
- # for the 10.5 SDK, unlikely somebody would have that but not
- # 10.6, I think.) If not found in some (old) default locations,
- # try the xcode-select tool.
+ # If no --with-macosx-sdk option is given, look for 10.6, 10.7
+ # and 10.8 SDKs, in that order. If not found in some (old)
+ # default locations, try the xcode-select tool.
# The intent is that for "most" Mac-based developers, a suitable
# SDK will be found automatically without any configure options.
@@ -2513,15 +2510,27 @@ if test "$_os" = "Darwin"; then
case "$with_macosx_sdk" in
10.4)
;;
+ 10.6)
+ ;;
+ *)
+ AC_MSG_WARN([Building with a SDK > 10.6 possibly breaks 10.6 compatibility. Do not use for the TDF build])
+ add_warning "Building with a SDK > 10.6 possibly breaks 10.6 compatibility. Do not use for the TDF build"
+ ;;
+ esac
+ ;;
+ 10.6)
+ case "$with_macosx_sdk" in
+ 10.6)
+ ;;
*)
- AC_MSG_WARN([Building with a SDK > 10.4 possibly breaks 10.4 compatibility. Do not use for the TDF build])
- add_warning "Building with a SDK > 10.4 possibly breaks 10.4 compatibility. Do not use for the TDF build"
+ AC_MSG_WARN([Building with a SDK > 10.6 possibly breaks 10.6 compatibility. Do not use for the TDF build])
+ add_warning "Building with a SDK > 10.6 possibly breaks 10.6 compatibility. Do not use for the TDF build"
;;
esac
;;
*)
- AC_MSG_WARN([Building with a minimum version requirement > 10.4 breaks 10.4 compatibility. Do not use for the TDF build])
- add_warning "Building with a minimum version requirement > 10.4 breaks 10.4 compatibility. Do not use for the TDF build"
+ AC_MSG_WARN([Building with a minimum version requirement > 10.6 breaks 10.6 compatibility. Do not use for the TDF build])
+ add_warning "Building with a minimum version requirement > 10.6 breaks 10.6 compatibility. Do not use for the TDF build"
;;
esac
fi