summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Gomez <agomez@igalia.com>2013-04-10 11:22:05 +0300
committerDavid Tardon <dtardon@redhat.com>2013-04-13 10:48:54 +0000
commitf3f9db6d1d1fe63a4323f43de91a13aae03b1228 (patch)
tree99052f8b4b432b7256bc656443cf0b827552da32 /configure.ac
parent3aa14b5a2f8d815ada281b69e9b8600e759fc5de (diff)
postgresql: honor --disable-openssl flag
On --disable-openssl, let's avoid linking the bundled postgresql to OpenSSL by not passing down --with-openssl to its configure script. Also, configure stage will fail if krb5 or gssapi are enabled as they need OpenSSL and, in any case, --with-krb5 and --with-gssapi will not be passed down to postgresql configure script. Change-Id: Iaf7e944d1d8f6a018e949ece56f6d3881f1e8c46 Reviewed-on: https://gerrit.libreoffice.org/3333 Tested-by: LibreOffice gerrit bot <gerrit@libreoffice.org> Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c5169eca4d2..75e149f923fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7731,6 +7731,13 @@ dnl ===================================================================
if test "x$enable_postgresql_sdbc" != "xno"; then
SCPDEFS="$SCPDEFS -DWITH_POSTGRESQL_SDBC"
+ if test "$with_krb5" = "yes" -a "$enable_openssl" = "no"; then
+ AC_MSG_ERROR([krb5 needs OpenSSL, but --disable-openssl was given.])
+ fi
+ if test "$with_gssapi" = "yes" -a "$enable_openssl" = "no"; then
+ AC_MSG_ERROR([GSSAPI needs OpenSSL, but --disable-openssl was given.])
+ fi
+
AC_MSG_CHECKING([PostgreSQL C interface])
if test "$with_system_postgresql" = "yes"; then
AC_MSG_RESULT([external PostgreSQL])