summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Gomez <agomez@igalia.com>2013-04-09 18:05:16 +0300
committerDavid Tardon <dtardon@redhat.com>2013-04-13 10:47:05 +0000
commitfd6d42395a676ba4a408b53725c8e4f9edf421cd (patch)
tree97ea0e1c04abf87d043261743dd2967b786f83fe /configure.ac
parent1e53d3b87aef18db7bce0c3990cc1403d1932fe2 (diff)
build: warn when configure with --with-tls=openssl
When expliciting openssl as tls implementation to use, show a warning as there are still some pieces of code that may depend on NSS or GNUTLS. Change-Id: I2cfaaf09b5ad83837928f2648975db956b261c19 Reviewed-on: https://gerrit.libreoffice.org/3327 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d00ebb78b1f..494de054bbc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8109,6 +8109,10 @@ if test -n "$with_tls"; then
openssl)
AC_DEFINE(USE_TLS_OPENSSL)
TLS=OPENSSL
+
+ # warn that OpenSSL has been selected but not all TLS code has this option
+ AC_MSG_WARN([TLS/SSL implementation to use is OpenSSL but some code may still be depending on NSS or GNUTLS])
+ add_warning "TLS/SSL implementation to use is OpenSSL but some code may still be depending on NSS or GNUTLS"
;;
nss)
AC_DEFINE(USE_TLS_NSS)