summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-10-29 17:26:45 +0100
committerMichael Stahl <mstahl@redhat.com>2013-10-30 00:01:35 +0100
commit76e1ff7bc8230d09092a9dae3942f949b388c5eb (patch)
treece1808e91f88aca0327cc80dfca9f51f3ebb2fbf /configure.ac
parentffa7f7b8ac6c6cb292f6b115c0601ac11d7a8f16 (diff)
configure: mozab-driver does not build with MSVC debug runtimes
link.exe complains about different settings of _ITERATOR_DEBUG_LEVEL and RuntimeLibrary in MCatalog.o and other objects (LNK2038). Change-Id: I4a63231c93d34edd3c20b6987ee8c9ed3b072ed5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2c8b4134aa9..b88d2e28d906 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3717,6 +3717,9 @@ if test -n "$enable_dbgutil" -a "$enable_dbgutil" != "no"; then
else
with_system_libcmis=no
fi
+ if test "$enable_win_mozab_driver" = "yes"; then
+ AC_MSG_ERROR([--enable-win-mozab-driver conflicts with --enable-dbgutil])
+ fi
else
ENABLE_DBGUTIL=""
MSVC_USE_DEBUG_RUNTIME=""