summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2023-04-05 12:32:58 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2023-04-18 14:30:11 +0200
commite39d4921bcd06836d5b28dc23628da41bcf463f7 (patch)
treee5607afa7b3813d59d3b78aeb28c83c70d4c1acb /configure.ac
parent11a25339abfb957ea51614b67bbff26cb606f3a2 (diff)
vscode: add Cygwin terminal profile and config for VS debugger for Windows
and also fix the gdb helper path for linux in one of the launch configurations, it used instdir for both the solenv as well as instdir paths. Change-Id: I2d2ad955e4c1d386071edc50af8fd0bdcffc66e3 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/150051 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 87c42a10f5cb..1958191469a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14676,10 +14676,13 @@ if test -n "$TMPDIR"; then
else
TEMP_DIRECTORY="/tmp"
fi
+CYGWIN_BASH="C:/cygwin64/bin/bash.exe"
if test "$build_os" = "cygwin"; then
TEMP_DIRECTORY=`cygpath -m "$TEMP_DIRECTORY"`
+ CYGWIN_BASH=`cygpath -m /usr/bin/bash`
fi
AC_SUBST(TEMP_DIRECTORY)
+AC_SUBST(CYGWIN_BASH)
# setup the PATH for the environment
if test -n "$LO_PATH_FOR_BUILD"; then