summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-05-26 20:28:37 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-05-27 13:02:43 +0200
commit46b5a714913d57105a82cff772f328107463a01d (patch)
treeac5cbdbfe1f5c05931195174e75a52b4123e6ef1 /configure.ac
parent256fccaf991cbc7d2f954c759e0ada6e2bd26c9e (diff)
avoid error message from configure about integer expression expected
Apparently test does not short-circuit evaluation. Change-Id: I0d9003735a43d0b5715b9d5fd9b5323efd6fdac1 Reviewed-on: https://gerrit.libreoffice.org/72999 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b5c499f7820e..b411ee9d92a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7533,7 +7533,7 @@ if test -n "$ENABLE_JAVA" -a -z "$JAVAINC"; then
fi
SOLARINC="$SOLARINC $JAVAINC"
-if test "$ENABLE_JAVA" != "" -a "x" != "x$JAVACOMPILER" -a "$_jdk_ver" -ge 10900; then
+if test "$ENABLE_JAVA" != "" -a "x" != "x$JAVACOMPILER" && test "$_jdk_ver" -ge 10900; then
url_check_unknown=0
java_base="testurlcheck"
java_src="${java_base}.java"