summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2019-06-14 00:46:32 +0000
committerJan-Marek Glogowski <glogow@fbihome.de>2019-06-15 02:37:28 +0200
commit77a3c443d35c7d966217f02ea9189cb1819c7828 (patch)
treedcc844f7e670305fad64d3a14837a26849c84d12 /configure.ac
parent41a1a91b6ec08d78449a199ec300ff73c85dd148 (diff)
tdf#125921 Qt5 set WM_CLASS for top level windows
Uses the same naming then the gtk3 backend, i.e. "libreoffice" for the instance name and different class names for the module windows, like "libreoffice-writer". These names are referenced in the desktop files a StartupWMClass and for example used to pin an app to the task bar. Change-Id: Ic9b8890536f6413ab59d2e0da866e2280ab3181a Reviewed-on: https://gerrit.libreoffice.org/74014 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 42d4b8f5f7ea..dbced920a118 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11145,7 +11145,9 @@ then
QT5_LIBS="-L$qt5_libdir -lQt5Core -lQt5Gui -lQt5Widgets -lQt5Network"
if test "$USING_X11" = TRUE; then
- QT5_LIBS="$QT5_LIBS -lQt5X11Extras"
+ PKG_CHECK_MODULES(QT5_XCB,[xcb],,[AC_MSG_ERROR([XCB not found, which is needed for correct app grouping in X11.])])
+ QT5_CFLAGS="$QT5_CFLAGS $QT5_XCB_CFLAGS"
+ QT5_LIBS="$QT5_LIBS $QT5_XCB_LIBS -lQt5X11Extras"
QT5_USING_X11=1
AC_DEFINE(QT5_USING_X11)
fi