summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2021-04-27 11:38:38 +0300
committerTor Lillqvist <tml@collabora.com>2021-04-27 15:40:12 +0200
commitbc35e5fe5922a71749c65a9b2d0412e4a3f34128 (patch)
treecb130e8a7b9a02c653e96d1adf13e12f32b32a1f /configure.ac
parent8ebb54c6c4937a151f2185e8f54b2c39e446368a (diff)
Accept macOS SDK 11.3
Change-Id: I210ae30e51d796990f88340da8b29f4c7080f5d2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/114702 Tested-by: Tor Lillqvist <tml@collabora.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e3fa28c32298..e24605fcb54f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3108,7 +3108,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-11.1 11.0 10.15 10.14 10.13}; do
+ for _macosx_sdk in ${with_macosx_sdk-11.3 11.1 11.0 10.15 10.14 10.13}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -3143,8 +3143,11 @@ if test $_os = Darwin; then
11.1)
MACOSX_SDK_VERSION=110100
;;
+ 11.3)
+ MACOSX_SDK_VERSION=110300
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.1])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.3])
;;
esac
@@ -3209,8 +3212,11 @@ if test $_os = Darwin; then
11.1)
MAC_OS_X_VERSION_MIN_REQUIRED="110100"
;;
+ 11.3)
+ MAC_OS_X_VERSION_MIN_REQUIRED="110300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.1])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.3])
;;
esac
@@ -3274,8 +3280,11 @@ if test $_os = Darwin; then
11.1)
MAC_OS_X_VERSION_MAX_ALLOWED="110100"
;;
+ 11.3)
+ MAC_OS_X_VERSION_MAX_ALLOWED="110300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.1])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.3])
;;
esac