summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-12-05 12:23:08 +0200
committerTor Lillqvist <tml@collabora.com>2013-12-05 12:38:57 +0200
commit215f87fb53164a5fc9af13acdad7fdada2117b60 (patch)
tree9e4bb0bc73a603dd81065eeb81545a4ff46996f9 /configure.ac
parentef8c2098a8528c0ca3cd9c66e23f4420f8660d19 (diff)
We need an ENABLE_CURL, too
It is not enough to just have CURL in BUILD_TYPE or not. At least the ftp UCP requires libcurl unconditionally, so it can't be built if we don't have either a system or bundled libcurl. Change-Id: I38e9939acb160d581e9a070a6cd7a0c89ddb5266
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7aad76191c31..c3ffe0560b31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8640,17 +8640,21 @@ if test "$with_system_curl" = "yes"; then
libo_MINGW_TRY_DLL([libgpg-error])
libo_MINGW_TRY_DLL([libgcrypt])
libo_MINGW_TRY_DLL([libssh2])
+ ENABLE_CURL=TRUE
elif test $_os = iOS; then
# Let's see if we need curl, I think not?
AC_MSG_RESULT([none])
+ ENABLE_CURL=
else
AC_MSG_RESULT([internal])
SYSTEM_CURL=NO
BUILD_TYPE="$BUILD_TYPE CURL"
+ ENABLE_CURL=TRUE
fi
AC_SUBST(SYSTEM_CURL)
AC_SUBST(CURL_CFLAGS)
AC_SUBST(CURL_LIBS)
+AC_SUBST(ENABLE_CURL)
dnl ===================================================================
dnl Check for system boost