summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-06-24 05:32:13 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2021-06-24 23:25:28 +0200
commit709a40e86734a4cbf67b65222e79db76aae56981 (patch)
tree461841e1c4238f659bd0d49931bd5bc091a81b89 /configure.ac
parent4abd2598f7816891af3bd462ffaee57f3423b9f9 (diff)
cross-toolset: fix real cross help building
Regression from commit 14069d84174ca7a4e60db4d75912903e9679b643 ("configure: Improve help-options handling"). We now must forward the help and extension configure options, as this is needed by the cross toolset to know, if it needs to build the HelpIndexer and HelpLinker executables. Also get rid of gb_Helper_optional_for_host. While it's in theory more correct, it makes gb_Helper_optional more complex, so we now rely on the fact, that the config_build.mk BUILD_TYPE is a subset of the config_host.mk BUILD_TYPE. This should fix the Windows Arm64 build, which currently seem to be the only cross-build including help. Change-Id: I8b90923c891b43cd2655b2578015c9bd579aae7d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/117758 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7ab1d3c802cd..f2053c85f503 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5346,8 +5346,12 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING([if we need to build the help index tooling])
if test "$with_help" = yes -o "$enable_extension_integration" != no; then
BUILD_TYPE="$BUILD_TYPE HELPTOOLS"
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
fi
AC_MSG_CHECKING([whether to enable xapian-omega support for online help])
@@ -5475,6 +5479,8 @@ if test "$cross_compiling" = "yes"; then
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
test "$with_galleries" = "no" -o -z "$WITH_GALLERY_BUILD" && sub_conf_opts="$sub_conf_opts --with-galleries=no --disable-database-connectivity"
+ test -n "$with_help" -a "$with_help" != "no" && sub_conf_opts="$sub_conf_opts --with-help=$with_help"
+ test "$enable_extensions" = yes || sub_conf_opts="$sub_conf_opts --disable-extensions"
test "$enable_wasm_strip" = "yes" && sub_conf_opts="$sub_conf_opts --enable-wasm-strip"
sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
@@ -5483,7 +5489,6 @@ if test "$cross_compiling" = "yes"; then
--build="$build_alias" \
--disable-cairo-canvas \
--disable-cups \
- --disable-extensions \
--disable-firebird-sdbc \
--disable-gpgmepp \
--disable-gstreamer-1-0 \
@@ -5524,6 +5529,7 @@ if test "$cross_compiling" = "yes"; then
GLM
GRAPHITE
HARFBUZZ
+ HELPTOOLS
ICU
LCMS2
LIBJPEG_TURBO