summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-02-20 18:18:40 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-02-20 23:15:52 +0100
commitc96855088af32849e0155e201dceb0e7c13ab05b (patch)
treeea09c116f7a7a3b17cd2411e4c923fb74fc29075 /configure.ac
parent4c11b51b349c2ad8e9019b4a84299e0cfd21b357 (diff)
macOS Xcode ld is known to always support -platform_version now
...after 358146bbbd1b9775c12770fb5e497b6ec5adfc51 "Bump macOS build baseline to Xcode 11.3 and macOS 10.14.4". This effectively reverts b7fd89100d8653dc73955780358fe31d38b68ebf "tdf#122218: Baseline Xcode 9.3 ld presumably doesn't support -platform_version". Change-Id: Ib79563babe3cc948556d5369b0f6b6a8d208cab2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/89160 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 77e4619f5022..afc41c0c555a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2793,7 +2793,6 @@ dnl ===================================================================
dnl Check macOS SDK and compiler
dnl ===================================================================
-HAVE_MACOS_LD_PLATFORMVERSION=
if test $_os = Darwin; then
# If no --with-macosx-sdk option is given, look for one
@@ -3028,16 +3027,6 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what macOS app bundle identifier to use])
MACOSX_BUNDLE_IDENTIFIER=$with_macosx_bundle_identifier
AC_MSG_RESULT([$MACOSX_BUNDLE_IDENTIFIER])
-
- AC_MSG_CHECKING([whether the linker supports -platform_version])
- save_LDFLAGS=$LDFLAGS
- LDFLAGS="$LDFLAGS -Xlinker -platform_version -Xlinker macos -Xlinker $MACOSX_DEPLOYMENT_TARGET \
- -Xlinker 0.0.0"
- AC_LINK_IFELSE([AC_LANG_PROGRAM()],
- [AC_MSG_RESULT([yes])
- HAVE_MACOS_LD_PLATFORMVERSION=TRUE],
- [AC_MSG_RESULT([no])])
- LDFLAGS=$save_LDFLAGS
fi
AC_SUBST(MACOSX_SDK_PATH)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
@@ -3049,7 +3038,6 @@ AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(MACOSX_PACKAGE_SIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
-AC_SUBST(HAVE_MACOS_LD_PLATFORMVERSION)
dnl ===================================================================
dnl Check iOS SDK and compiler