summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noelgrandin@gmail.com>2021-12-15 19:18:58 +0200
committerNoel Grandin <noel.grandin@collabora.co.uk>2021-12-15 20:09:18 +0100
commitd023a95526b8277775927c6ef3bf39925c77f76b (patch)
treecc94755ca1eceaef198c36e7759e685988b940f9 /configure.ac
parent79ca2a6a7c8e0102aa8e7e3af709d5cf2e4d9532 (diff)
add support for macOS SDK 12.1
Change-Id: I30d816d5926e5b1771901c697b67eb275d122636 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/126890 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9e15af8f3f6f..6bc4deb0479c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3251,7 +3251,7 @@ if test $_os = Darwin; then
# The SDK in the currently selected Xcode should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for macosx_sdk in 12.0 11.3 11.1 11.0 10.15 10.14 10.13; do
+ for macosx_sdk in 12.1 12.0 11.3 11.1 11.0 10.15 10.14 10.13; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
break
@@ -3290,6 +3290,9 @@ if test $_os = Darwin; then
12.0)
MACOSX_SDK_VERSION=120000
;;
+ 12.1)
+ MACOSX_SDK_VERSION=120100
+ ;;
*)
AC_MSG_ERROR([macOS SDK $macosx_sdk is not supported])
;;
@@ -3356,8 +3359,11 @@ if test $_os = Darwin; then
12.0)
MAC_OS_X_VERSION_MIN_REQUIRED="120000"
;;
+ 12.1)
+ MAC_OS_X_VERSION_MIN_REQUIRED="120100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.12--12.0])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.12--12.1])
;;
esac
@@ -3421,8 +3427,11 @@ if test $_os = Darwin; then
12.0)
MAC_OS_X_VERSION_MAX_ALLOWED="120000"
;;
+ 12.1)
+ MAC_OS_X_VERSION_MAX_ALLOWED="120100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.12--12.0])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.12--12.1])
;;
esac