summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-06-08 16:57:49 +0200
committerjan iversen <jani@libreoffice.org>2017-06-11 11:23:08 +0200
commit2a6894e05cb8b35376c47ad6301f4dc8deb56fc0 (patch)
treebc508fadb76ef742dfcb12b28df0a1cb9ccf7f14 /configure.ac
parente1b98561d3f48d0382c968b42e555038d88c3337 (diff)
iOS, support for armv7 and arm64 in configure.ac
This is the first patch in a serie, to get the iOS toolchain to actually produce the right code for simulator as well as iPhone (old models) and iPad (all models) Changes: --enable-ios-simulator removed no longer needed --enable-64-bit is no longer needed for iOS builds --host and --build no longer support arm-darwin.... but instead support armv7-darwin and arm64-darwin e.g. --host=armv7-darvin... --build=i386-darwain... builds iOS for the simulator in 32 bit mode. The works, the other modes (64bit simulator, native armv7 and arm64) are still highly experimental dist will be updated when all modes work. Change-Id: I82477d8415a4d62803da0fc80da6890d5db542d5 Reviewed-on: https://gerrit.libreoffice.org/38576 Reviewed-by: jan iversen <jani@libreoffice.org> Tested-by: jan iversen <jani@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 16 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 22dc6e90ba0e..1bdb40ce2c30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -719,7 +719,7 @@ darwin*) # Mac OS X or iOS
test_freetype=no
test_fontconfig=no
test_dbus=no
- if test "$host_cpu" = "arm"; then
+ if test "$host_cpu" = "armv7" -o "$host_cpu" = "arm64"; then
_os=iOS
test_gtk=no
test_cups=no
@@ -1373,7 +1373,7 @@ AC_ARG_ENABLE(ccache,
AC_ARG_ENABLE(64-bit,
AS_HELP_STRING([--enable-64-bit],
[Build a 64-bit LibreOffice on platforms where the normal build is 32-bit.
- At the moment meaningful only for iOS and Windows.]), ,)
+ At the moment meaningful only for Windows.]), ,)
libo_FUZZ_ARG_ENABLE(online-update,
AS_HELP_STRING([--enable-online-update],
@@ -1445,11 +1445,6 @@ AC_ARG_WITH(package-version,
[Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
,)
-AC_ARG_ENABLE(ios-simulator,
- AS_HELP_STRING([--enable-ios-simulator],
- [Build for the iOS Simulator, not iOS device.]),
-,)
-
libo_FUZZ_ARG_ENABLE(readonly-installset,
AS_HELP_STRING([--enable-readonly-installset],
[Prevents any attempts by LibreOffice to write into its installation. That means
@@ -2956,19 +2951,24 @@ dnl Check iOS SDK and compiler
dnl ===================================================================
if test $_os = iOS; then
-
- if test "$enable_64_bit" = "" -o "$enable_64_bit" = "no"; then
- :
- else
+ if test "$host_cpu" = "arm64"; then
BITNESS_OVERRIDE=64
fi
AC_MSG_CHECKING([what iOS SDK to use])
- if test "$enable_ios_simulator" = yes; then
+ if test "$build_cpu" = "i386"; then
platform=iPhoneSimulator
+ XCODE_ARCHS=i386
+ versionmin=-mios-simulator-version-min=9.3
+ elif test "$build_cpu" = "x86_64"; then
+ platform=iPhoneSimulator
+ XCODE_ARCHS=x86_64
+ versionmin=-mios-simulator-version-min=9.3
else
platform=iPhoneOS
+ XCODE_ARCHS=$host_cpu
+ versionmin=-miphoneos-version-min=9.3
fi
xcode_developer=`xcode-select -print-path`
@@ -2991,24 +2991,6 @@ if test $_os = iOS; then
XCODEBUILD_SDK=`echo $platform | tr A-Z a-z`$ios_sdk
- if test "$enable_ios_simulator" = yes; then
- if test "$BITNESS_OVERRIDE" = 64; then
- XCODE_ARCHS=x86_64
- versionmin=-mios-simulator-version-min=9.3
- else
- XCODE_ARCHS=i386
- versionmin=-mios-simulator-version-min=9.3
- fi
- else
- platform=iPhoneOS
- if test "$BITNESS_OVERRIDE" = 64; then
- XCODE_ARCHS=arm64
- else
- XCODE_ARCHS=armv7
- fi
- versionmin=-miphoneos-version-min=9.3
- fi
-
# LTO is not really recommended for iOS builds,
# the link time will be astronomical
if test "$ENABLE_LTO" = TRUE; then
@@ -8792,7 +8774,7 @@ if test $_os != iOS -a $_os != Android -a "$enable_fuzzers" != "yes"; then
AC_DEFINE(HAVE_FEATURE_NSS)
ENABLE_NSS="TRUE"
AC_DEFINE(ENABLE_NSS)
-else
+elif test $_os != iOS ; then
with_tls=openssl
fi
AC_SUBST(ENABLE_NSS)
@@ -8819,6 +8801,9 @@ if test -n "$with_tls"; then
AC_DEFINE(USE_TLS_NSS)
TLS=NSS
;;
+ no)
+ AC_MSG_WARN([Skipping TLS/SSL])
+ ;;
*)
AC_MSG_ERROR([unsupported implementation $with_tls. Supported are:
openssl - OpenSSL