summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2015-07-27 08:02:15 +0200
committerMichael Stahl <mstahl@redhat.com>2015-07-29 10:56:02 +0000
commitef8ddd22a9f434fc4de1f4b212ff2467676f576c (patch)
tree85ef24e7481102230422ac659d2831a3ca7ae421 /configure.ac
parentd9162d24ce242f27f9cc0430f0650daac8e5db24 (diff)
Fix -showIncludes generation on MSVC 14.0
Change-Id: I486b2fc9b4d538ac59d4ced41f2c1726d1ad0dfa Reviewed-on: https://gerrit.libreoffice.org/17358 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-x[-rw-r--r--]configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ed350101e10e..c97617aed1c4 100644..100755
--- a/configure.ac
+++ b/configure.ac
@@ -3696,7 +3696,7 @@ if test "$_os" = "WINNT"; then
dnl localized
AC_MSG_CHECKING([the dependency generation prefix (cl.exe -showIncludes)])
echo "#include <stdlib.h>" > conftest.c
- SHOWINCLUDES_PREFIX=`$CC -c -showIncludes conftest.c 2>/dev/null | \
+ SHOWINCLUDES_PREFIX=`$CC $CFLAGS -c -showIncludes conftest.c 2>/dev/null | \
grep 'stdlib\.h' | head -n1 | sed 's/ [[[:alpha:]]]:.*//'`
rm -f conftest.c conftest.obj
if test -z "$SHOWINCLUDES_PREFIX"; then