summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2022-09-07 21:34:42 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2022-09-08 14:43:53 +0200
commitfd42cea5f301a10cdeaa29959f04b111de534132 (patch)
tree0bfa9e9f22d63dcbb6eeafc6002752d9ff20399e /configure.ac
parent09e499e64ec4acb24c9524c8aacabc6182124442 (diff)
replace egrep/fgrep calls with grep -E/grep -F
as egrep/fgrep is deprecated since long amd grep 3.8+ now actually warns (e.g. "egrep: warning: egrep is obsolescent; using grep -E") Change-Id: I5b10f05dffdd09081deb05cef974e3cdb2907315 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/139614 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> Tested-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7b03df8ee0aa..7c82578933cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2945,7 +2945,7 @@ AC_SUBST(GNUPARALLEL)
AC_MSG_CHECKING([for GNU or BSD tar])
for a in $GNUTAR gtar gnutar tar bsdtar /usr/sfw/bin/gtar; do
- $a --version 2> /dev/null | egrep "GNU|bsdtar" 2>&1 > /dev/null
+ $a --version 2> /dev/null | grep -E "GNU|bsdtar" 2>&1 > /dev/null
if test $? -eq 0; then
GNUTAR=$a
break
@@ -2958,11 +2958,11 @@ fi
AC_SUBST(GNUTAR)
AC_MSG_CHECKING([for tar's option to strip components])
-$GNUTAR --help 2> /dev/null | egrep "bsdtar|strip-components" 2>&1 >/dev/null
+$GNUTAR --help 2> /dev/null | grep -E "bsdtar|strip-components" 2>&1 >/dev/null
if test $? -eq 0; then
STRIP_COMPONENTS="--strip-components"
else
- $GNUTAR --help 2> /dev/null | egrep "strip-path" 2>&1 >/dev/null
+ $GNUTAR --help 2> /dev/null | grep -E "strip-path" 2>&1 >/dev/null
if test $? -eq 0; then
STRIP_COMPONENTS="--strip-path"
else