summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2013-07-02 17:57:36 +0100
committerMichael Meeks <michael.meeks@suse.com>2013-07-02 21:59:30 +0100
commit3887ba5677b1902fcf45f076d7a8e3ac96322dff (patch)
tree8428bc9ad7b839d272dfc1bd3e22463faddffc34 /configure.ac
parent74b5f592dbbd499ef4c50601e92e393623244c4c (diff)
Fix opencl path and linking issues on windows.
Change-Id: Ie39a3c02d6021ae200d6e3939ec9a14ed7f34d21
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 66733ea775fd..fdca180cd682 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9840,8 +9840,14 @@ elif test "z$with_opencl_sdk" = "z"; then
else
if test -d "$with_opencl_sdk/include"; then
ENABLE_OPENCL=TRUE
- OPENCL_CFLAGS="-I$with_opencl_sdk/include"
- OPENCL_LIBS="-L$with_opencl_sdk/lib/x86 -lOpenCL"
+ if test "$_os" = "WINNT"; then
+ PathFormat "$with_opencl_sdk"
+ OPENCL_CFLAGS="-I$formatted_path/include"
+ OPENCL_LIBS="-LIBPATH:$formatted_path/lib/x86 OpenCL.lib"
+ else
+ OPENCL_CFLAGS="-I$with_opencl_sdk/include"
+ OPENCL_LIBS="-L$with_opencl_sdk/lib/x86 -lOpenCL"
+ fi
AC_MSG_RESULT([found at path $with_opencl_sdk])
AC_DEFINE(HAVE_FEATURE_OPENCL)
else