summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2013-06-20 13:57:45 +0200
committerStephan Bergmann <sbergman@redhat.com>2013-06-20 14:02:48 +0200
commit5ba3d1740b03efa394b2d2bf34fb8a8d3db2331d (patch)
tree2461205effc5d998cc2c92aad4c8945df5f8f7e6 /configure.ac
parente79b6715070cdb4512d8ead784103930ebe8b221 (diff)
Clean up declaration of __cxa_get_globals
At least Clang trunk towards 3.4 now rejects incompatible declarations of the same extern "C" function in different namespaces, so that trick of getting at the function that is exported by libstdc++ but only rudimentarily if at all exposed in cxxabi.h no longer worked. TODO: This change should be reflected in any other bridges where it is relevant, too. Change-Id: Ie3ccbdb7d75cc98636d02c0435958532620724f2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97293ad3d400..9998743d87e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5571,6 +5571,17 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
CFLAGS=$save_CFLAGS
+
+ AC_MSG_CHECKING([whether $CXX declares __cxa_get_globals in cxxabi.h])
+ AC_LANG_PUSH([C++])
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <cxxabi.h>
+ void * f() { return __cxxabiv1::__cxa_get_globals(); }
+ ])], [
+ AC_DEFINE([HAVE_GCC_CXXABI_H_CXA_GET_GLOBALS],[1])
+ AC_MSG_RESULT([yes])
+ ], [AC_MSG_RESULT([no])])
+ AC_LANG_POP([C++])
fi
AC_SUBST(HAVE_GCC_NO_LONG_DOUBLE)
@@ -12051,6 +12062,7 @@ fi
AC_CONFIG_FILES([config_host.mk Makefile lo.xcent instsetoo_native/util/openoffice.lst])
AC_CONFIG_HEADERS([config_host/config_clang.h])
AC_CONFIG_HEADERS([config_host/config_features.h])
+AC_CONFIG_HEADERS([config_host/config_gcc.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_lgpl.h])