summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2013-07-16 09:53:29 +0200
committerLuboš Luňák <l.lunak@suse.cz>2013-07-16 09:58:39 +0200
commitafb41ff0c5bfc5402c1a5522a55998d6c023b248 (patch)
treed89035410119187b08166279c080962e7dfe81f0 /configure.ac
parent56f484fd648b459b32842b66c32f8945115ed509 (diff)
warn in configure about using ccache+clang without CCACHE_CPP2 set
- causes warnings about unused -I options, because they are preprocessing options and Clang complains that they are unused in pure compilation - Clang supresses some warnings from expansions of macros in system headers, but those would be already expanded and thus warned about - Clang prints relevant source lines with errors/warnings in them and would show them preprocessed (this should actually apply to GCC4.8+ too) Change-Id: I02c86c43a657d078e347e4ecd5c1e2ff07db2886
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc439e08a9a3..365391d205ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2896,6 +2896,13 @@ if test "$GCC" = "yes"; then
fi
AC_SUBST(COM_GCC_IS_CLANG)
+if test "$CCACHE" != "" -a "$COM_GCC_IS_CLANG" = TRUE; then
+ if test -z "$CCACHE_CPP2"; then
+ AC_MSG_WARN([Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings.])
+ add_warning "Using ccache with Clang without CCACHE_CPP2 set causes spurious warnings."
+ fi
+fi
+
# ===================================================================
# check various GCC options that Clang does not support now but maybe
# will somewhen in the future, check them even for GCC, so that the