summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-07-10 21:01:11 -0500
committerPetr Mladek <pmladek@suse.cz>2013-07-11 13:11:46 +0000
commitd496bcdb770a61400abf4f67baae5103505f8a34 (patch)
tree252fd0a6eff556a4bd17e1dc73e2b103340980a4 /configure.ac
parent25b4ecbbcf9af9aeea5ca093b138f108de35a353 (diff)
we do not support any platform with bison < 2.0 anymore
Change-Id: Ia2c1c6ed43c6a42fa1a65a22f4c8d68de216706c Reviewed-on: https://gerrit.libreoffice.org/4822 Reviewed-by: Petr Mladek <pmladek@suse.cz> Tested-by: Petr Mladek <pmladek@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 69479c3f2334..3db18131c587 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9219,29 +9219,17 @@ dnl ***************************************
dnl Checking for bison and flex
dnl ***************************************
AC_PATH_PROG(BISON, bison)
-ANCIENT_BISON="NO"
if test -z "$BISON"; then
AC_MSG_ERROR([no bison found in \$PATH, install it])
else
AC_MSG_CHECKING([the bison version])
_bison_version=`$BISON --version | grep GNU | $SED -e 's@^[[^0-9]]*@@' -e 's@ .*@@' -e 's@,.*@@'`
_bison_longver=`echo $_bison_version | $AWK -F. '{ print \$1*1000+\$2}'`
- # Accept newer than 1.875 or older(equal) than 1.75
- if test "$_bison_longver" -ge 1875 -o "$_bison_longver" -le 1075; then
- if test "$_bison_version" = "1.875"; then
- AC_MSG_WARN([suspect ($BISON $_bison_version)])
- add_warning "Suspect ($BISON $_bison_version) suggest upgrade"
- else
- AC_MSG_RESULT([checked ($BISON $_bison_version)])
- fi
- else
- AC_MSG_ERROR([failed ($BISON $_bison_version need 1.875+ (or 1.75 and older))])
- fi
+ # Accept newer than 2.0
if test "$_bison_longver" -lt 2000; then
- ANCIENT_BISON="YES"
+ AC_MSG_ERROR([failed ($BISON $_bison_version need 2.0+)])
fi
fi
-AC_SUBST(ANCIENT_BISON)
AC_PATH_PROG(FLEX, flex)
if test -z "$FLEX"; then