summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2020-08-06 20:52:01 +0300
committerMike Kaganski <mike.kaganski@collabora.com>2020-09-15 10:53:11 +0200
commit315919306c7b6e95db6a280c4aa8d2203970e292 (patch)
tree6cf8bdbffed6eb597a4a5ed790d8a7d37ce0d4d9 /configure.ac
parent485a8a8f21f951d19586b694c233eb4a2dd7b57a (diff)
Set PYTHONWARNINGS to error by default for --enable-werror
Setting it in environment overrides this setting. The rationale is to avoid introducing warnings like these appeared recently: zipfile.py:1517: UserWarning: Duplicate name: 'cmd/ar/sc_bulletsandnumberingdialog.png' (see e.g. https://ci.libreoffice.org/job/gerrit_windows/71910/consoleFull) Change-Id: I8ae42e039ec3d028c01dbc4bcf422feae9e46271 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/100268 Tested-by: Jenkins Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5ab4159e17f..8b3097fb4c2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5136,16 +5136,19 @@ dnl ===================================================================
AC_MSG_CHECKING([whether to turn warnings to errors])
if test -n "$enable_werror" -a "$enable_werror" != "no"; then
ENABLE_WERROR="TRUE"
+ PYTHONWARNINGS="error"
AC_MSG_RESULT([yes])
else
if test -n "$LODE_HOME" -a -z "$enable_werror"; then
ENABLE_WERROR="TRUE"
+ PYTHONWARNINGS="error"
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
fi
fi
AC_SUBST(ENABLE_WERROR)
+AC_SUBST(PYTHONWARNINGS)
dnl Check for --enable-assert-always-abort, set ASSERT_ALWAYS_ABORT
dnl ===================================================================