summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2022-01-03 00:16:45 +0100
committerJan-Marek Glogowski <glogow@fbihome.de>2022-01-03 11:23:36 +0100
commit383616c2c0c9e6874a714d7f494e5a2ec1a3f08d (patch)
tree41d00f1a09aa68859dff68bbc2fb49ae3860323b /configure.ac
parentb4164ec443650f77aa472fc0d06e6dba716e2d28 (diff)
freetype/fontconfig: ignore --without-system-libs
Since commit 8677e994d37329a28ca8278358a99d18b9cada69 ("Simplify FONTCONFIG and FREETYPE tests"), these tests adhered to the ${with_system_libs} setting, which might not be desirable. As a result commit 4e7f3692c9eb42a00797025289782baa69a42cc7 ("Make external/freetype use -fPIC") is needed as a linking fix. This still keeps the possibility to build with internal freetype and fontconfig. This also adds a new macro option, "test-system", which follows the $test_system_* variable without additional configure switches. Change-Id: Ifed91fdc6e4a77f708a3dbbd784b6069bf2a61b7 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/127878 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9aa2243b535a..e31f755866dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1146,6 +1146,7 @@ test "${test_xrender+set}" = set || test_xrender="$using_x11"
test "${using_headless_plugin+set}" = set || using_headless_plugin="$using_freetype_fontconfig"
test "${test_gtk3_kde5+set}" != set -a "$test_kf5" = yes -a "$test_gtk3" = yes && test_gtk3_kde5="yes"
+# Make sure fontconfig and freetype test both either system or not
test "${test_system_fontconfig+set}" != set -a "${test_system_freetype+set}" = set && test_system_fontconfig="$test_system_freetype"
test "${test_system_freetype+set}" != set -a "${test_system_fontconfig+set}" = set && test_system_freetype="$test_system_fontconfig"
@@ -5869,7 +5870,7 @@ fi
AC_SUBST(ENABLE_CUPS)
-libo_CHECK_SYSTEM_MODULE([fontconfig],[FONTCONFIG],[fontconfig >= 2.4.1],,system)
+libo_CHECK_SYSTEM_MODULE([fontconfig],[FONTCONFIG],[fontconfig >= 2.4.1],,system,TRUE)
dnl whether to find & fetch external tarballs?
dnl ===================================================================
@@ -9458,7 +9459,7 @@ if test "x$ac_config_site_64bit_host" = xYES; then
else
FREETYPE_LIBS_internal="-L${WORKDIR}/UnpackedTarball/freetype/instdir/lib -lfreetype"
fi
-libo_CHECK_SYSTEM_MODULE([freetype],[FREETYPE],[freetype2 >= 9.9.3],,system)
+libo_CHECK_SYSTEM_MODULE([freetype],[FREETYPE],[freetype2 >= 9.9.3],,system,TRUE)
# ===================================================================
# Check for system libxslt