summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2023-03-11 21:22:55 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2023-03-12 01:06:08 +0000
commit5f20f4ff21f597e55d899f5ea4dfe1c1fa5824bc (patch)
treecea68bcbf3860ab0c84b5dbf8931fd505ea07c90 /configure.ac
parentf5c466502a302b8e56486119e5e318fb02b479fe (diff)
cross-compiling on windows needs openssl to build internal python
→ add back OPENSSL as a permissable sub-build target and explicitly enable openssl when cross-compiling for windows_aarch64 partially reverts 4132bd5477c25a505f7bfbee1e7dcf6602c927d3 Change-Id: Ic162a2f0c6db377eadedb149fb428f0f015539f9 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/148688 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d8ec4664bd25..17fa8afac23a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5689,6 +5689,9 @@ if test "$cross_compiling" = "yes"; then
sub_conf_opts="$sub_conf_opts --with-main-module=writer"
fi
fi
+ # windows uses full-internal python and that in turn relies on openssl, so also enable openssl
+ # when cross-compiling for aarch64, overriding the defaults below
+ test "${PLATFORMID}" = "windows_aarch64" && sub_conf_opts="$sub_conf_opts --enable-openssl --with-tls=openssl"
# Don't bother having configure look for stuff not needed for the build platform anyway
# WARNING: any option with an argument containing spaces must be handled separately (see --with-theme)
@@ -5772,6 +5775,7 @@ if test "$cross_compiling" = "yes"; then
LIBXSLT
MDDS
NATIVE
+ OPENSSL
ORCUS
PYTHON
SCRIPTING