summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAleksei Nikiforov <darktemplar@basealt.ru>2019-01-09 17:27:03 +0300
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2019-01-11 14:42:25 +0100
commit72385abba9d02670349e18478cef4bf53b330cda (patch)
tree20a5cac3f68aae5ef92c16a64a72dac7c4eb6c20 /configure.ac
parent70519a43e0d89a6b5d89859a6851f8c757c6b0c7 (diff)
KDE5: return multilib support
Change-Id: Id416ff399e443175b7c7d608c8a7a4bc38eeedcf Reviewed-on: https://gerrit.libreoffice.org/66145 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13551d6f3749..0a6db77f230d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10907,6 +10907,20 @@ AC_SUBST(ENABLE_SCRIPTING_JAVASCRIPT)
AC_SUBST(SYSTEM_RHINO)
AC_SUBST(RHINO_JAR)
+# This is only used in Qt5/KDE5 checks to determine if /usr/lib64
+# paths should be added to library search path. So lets put all 64-bit
+# platforms there.
+supports_multilib=
+case "$host_cpu" in
+x86_64 | powerpc64 | powerpc64le | s390x | aarch64 | mips64 | mips64el)
+ if test "$SAL_TYPES_SIZEOFLONG" = "8"; then
+ supports_multilib="yes"
+ fi
+ ;;
+*)
+ ;;
+esac
+
dnl ===================================================================
dnl QT5 Integration
dnl ===================================================================