summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2023-02-27 13:12:01 +0100
committerStephan Bergmann <sbergman@redhat.com>2023-02-27 18:38:13 +0000
commit788dd3e7fb24c681716608a8bf0339df8c78e4e5 (patch)
tree01e77d6335a207e38efb59684ef1a56509d6f644 /configure.ac
parent64914560e279c71ff1233f4bab851e2a292797e6 (diff)
Note that Clang consteval bugs are meanwhile fixed
Change-Id: I90b2765bdad5fe753288420b01a5395bcf22f44f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/147885 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4d523b097109..f2b95c279951 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14344,13 +14344,13 @@ dnl from consteval constructor initializing const variable",
dnl <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=98752> "wrong 'error: ‘this’ is not a constant
dnl expression' with consteval constructor", <https://bugs.llvm.org/show_bug.cgi?id=50063> "code
dnl using consteval: 'clang/lib/CodeGen/Address.h:38: llvm::Value*
-dnl clang::CodeGen::Address::getPointer() const: Assertion `isValid()' failed.'",
-dnl <https://developercommunity.visualstudio.com/t/1581879> "Bogus error C7595 with consteval
-dnl constructor in ternary expression (/std:c++latest)", or
+dnl clang::CodeGen::Address::getPointer() const: Assertion `isValid()' failed.'" (which should be
+dnl fixed since Clang 14), <https://developercommunity.visualstudio.com/t/1581879> "Bogus error
+dnl C7595 with consteval constructor in ternary expression (/std:c++latest)", or
dnl <https://github.com/llvm/llvm-project/issues/54612> "C++20, consteval, anonymous union:
dnl llvm/lib/IR/Instructions.cpp:1491: void llvm::StoreInst::AssertOK(): Assertion
dnl `cast<PointerType>(getOperand(1)->getType())->isOpaqueOrPointeeTypeMatches(getOperand(0)->getType())
-dnl && "Ptr must be a pointer to Val type!"' failed.":
+dnl && "Ptr must be a pointer to Val type!"' failed." (which should be fixed since Clang 17):
AC_LANG_PUSH([C++])
save_CXX=$CXX
if test "$COM" = MSC && test "$COM_IS_CLANG" != TRUE; then