summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2022-02-21 15:49:52 +0100
committerMichael Weghorn <m.weghorn@posteo.de>2022-02-22 10:18:46 +0100
commitc688fd1393dccfb3df39bd05cceed1cf0c401b02 (patch)
tree6c6ce782667940d6e36f883addc619cca9ceab09 /configure.ac
parentbcaf13205052a64373599245ae0b1020b04b1385 (diff)
gtk3 a11y: Require atk >= 2.28.1, drop code for < 2.15.2
README.md lists RHEL 7 or CentOS 7 as runtime baseline, which has ATK 2.28.1 [1]. Therefore, check for that version in configure.ac and drop some code for versions < 2.15.2. Requiring 2.28.1 as minimum ATK version will allow for further cleanup in follow-up commits. [1] https://centos.pkgs.org/7/centos-x86_64/atk-2.28.1-2.el7.x86_64.rpm.html Change-Id: Id7084366d2359deb60948b8969c1d3dcc68ddb47 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/130328 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index af1da0103177..b22d8e17c6da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11639,7 +11639,7 @@ if test "$test_gtk3" = yes -a "x$enable_gtk3" = "xyes" -o "x$enable_gtk3_kde5" =
add_warning 'Non-system cairo combined with gtk3 is assumed to cause trouble; proceed at your own risk.'
fi
: ${with_system_cairo:=yes}
- PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.20 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo)
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.20 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 atk >= 2.28.1 cairo)
GTK3_CFLAGS=$(printf '%s' "$GTK3_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
FilterLibs "${GTK3_LIBS}"