summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2015-12-10 16:57:36 +0200
committerTor Lillqvist <tml@collabora.com>2015-12-10 17:01:19 +0200
commitcf029192e4ac9ce0e24ddfd880f5f9d557cf9c28 (patch)
treeb0ad24e53f22dd7f20eb38e81d1375e0a768e4ab /configure.ac
parent9ad6f07e0b5494e55d70642120f173961845ce30 (diff)
Add --with-prebuilt-openssl
Don't ask. Oh well, if you want to know: For some people, like me, Cygwin and its Perl run into horrible trouble with the fork() emulation when building OpenSSL. (But my Cygwin works fine for all else in the build. Go figure.) So I came up with a way to use prebuilt OpenSSL binaries. Not to be used for release builds, of course (and the configury checks for that), as long as our policy is to build all we can from sources. Change-Id: Ic303bdf0c620c5122aca3d646fa1f0587221e70f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e1c51a3b18b..157e7bc88692 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1473,6 +1473,11 @@ AC_ARG_ENABLE(openssl,
use only if you are hacking on it.]),
,enable_openssl=yes)
+AC_ARG_WITH(prebuilt-openssl,
+ AS_HELP_STRING([--with-prebuilt-openssl],
+ [Don't build OpenSSL but use prebuilt binaries. Only for use on Windows, when you can't build it,
+ thanks to the Cygwin fork() problem when running the Perl disaster in OpenSSL's build system.]))
+
AC_ARG_ENABLE(library-bin-tar,
AS_HELP_STRING([--enable-library-bin-tar],
[Enable the building and reused of tarball of binary build for some 'external' libraries.
@@ -8943,6 +8948,10 @@ if test "$with_system_nss" = "yes"; then
libo_MINGW_CHECK_DLL([ssl3])
fi
+if test $_os = WINNT -a -z "$ENABLE_RELEASE_BUILD" -a "$with_prebuilt_openssl" = yes; then
+ BUILD_TYPE="$BUILD_TYPE PREBUILT_OPENSSL"
+fi
+
dnl ===================================================================
dnl Check for system mozilla headers
dnl ===================================================================