summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2023-08-18 09:58:09 +0200
committerMichael Weghorn <m.weghorn@posteo.de>2023-10-17 13:45:59 +0200
commitd6d4cae126cf8e8fc73b54b852d75c8b0a0db65e (patch)
treeae3c2ea6989ade791b1d2580b2e2c7115b9c46a5 /configure.ac
parentce81efb31c311dc835d2e1572751964dbe8e6aa6 (diff)
Bump Java build baseline from JDK 9 to 17
As discussed in the ESC call on 2023-08-10 [1], bump the Java build baseline to 17. This should not affect the Java runtime requirement, since the target version is explicitly specified already. [1] https://lists.freedesktop.org/archives/libreoffice/2023-August/090759.html Change-Id: I18251151392ca5edec8ca3d5cffd192d5f9f38b1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/155827 Tested-by: Jenkins Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 32c2eecfbc7a..189ef4a55222 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2548,7 +2548,7 @@ AC_ARG_WITH(linker-hash-style,
AC_ARG_WITH(jdk-home,
AS_HELP_STRING([--with-jdk-home=<absolute path to JDK home>],
- [If you have installed JDK 9 or later on your system please supply the
+ [If you have installed JDK 17 or later on your system please supply the
path here. Note that this is not the location of the java command but the
location of the entire distribution. In case of cross-compiling, this
is the JDK of the host os. Use --with-build-platform-configure-options
@@ -8580,7 +8580,7 @@ if test "$ENABLE_JAVA" != ""; then
fi
if ! test -f "$with_jdk_home/lib/jvm.lib" -a -f "$with_jdk_home/bin/java.exe"; then
- AC_MSG_ERROR([No JDK found, pass the --with-jdk-home option (or fix the path) pointing to a $WIN_HOST_BITS-bit JDK >= 9])
+ AC_MSG_ERROR([No JDK found, pass the --with-jdk-home option (or fix the path) pointing to a $WIN_HOST_BITS-bit JDK >= 17])
fi
fi
@@ -8665,8 +8665,8 @@ if test "$ENABLE_JAVA" != "" -a "$cross_compiling" != "yes"; then
_jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED '/^$/d' | $SED s/[[-A-Za-z]]*//`
_jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
- if test "$_jdk_ver" -lt 90000; then
- AC_MSG_ERROR([JDK is too old, you need at least 9 ($_jdk_ver < 90000)])
+ if test "$_jdk_ver" -lt 170000; then
+ AC_MSG_ERROR([JDK is too old, you need at least 17 ($_jdk_ver < 170000)])
fi
dnl TODO: Presumably, the Security Manager will not merely be disallowed, but be
dnl completely removed in some Java version > 18 (see
@@ -8687,7 +8687,7 @@ if test "$ENABLE_JAVA" != "" -a "$cross_compiling" != "yes"; then
JAVACFLAGS=-J-Xmx128M
fi
else
- AC_MSG_ERROR([Java not found. You need at least JDK 9])
+ AC_MSG_ERROR([Java not found. You need at least JDK 17])
fi
else
if test -z "$ENABLE_JAVA"; then