summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2022-01-05 08:20:16 +0100
committerStephan Bergmann <sbergman@redhat.com>2022-01-05 17:50:41 +0100
commitdf9cbdd22658131b881e6527467c8e2a2dd36c70 (patch)
tree1e4a1ce9f4e225e94ed17e86f0596ddb1bddbc4c /configure.ac
parenteb31b387ac4b679e4da851b8b17e9b4e35722c04 (diff)
Drop remnants of --with-webdav=neon
...that were left behind by 023ebf17898db4bca63129f079fd90b5cf76c1a9 "ucb: remove --with-webdav=neon" Change-Id: I617ca74d1c4b46d8f0b9dac317b5972bfb911813 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/127986 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 4 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 9b5fbda9e868..a7c23de74122 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1904,7 +1904,7 @@ AC_ARG_ENABLE(bogus-pkg-config,
AC_ARG_ENABLE(openssl,
AS_HELP_STRING([--disable-openssl],
[Disable using libssl/libcrypto from OpenSSL. If disabled,
- components will either use GNUTLS or NSS. Work in progress,
+ components will use NSS. Work in progress,
use only if you are hacking on it.]),
,enable_openssl=yes)
@@ -1916,7 +1916,7 @@ libo_FUZZ_ARG_ENABLE(cipher-openssl-backend,
AC_ARG_ENABLE(nss,
AS_HELP_STRING([--disable-nss],
[Disable using NSS. If disabled,
- components will either use GNUTLS or openssl. Work in progress,
+ components will use openssl. Work in progress,
use only if you are hacking on it.]),
,enable_nss=yes)
@@ -10486,8 +10486,8 @@ if test -n "$with_tls"; then
fi
# warn that OpenSSL has been selected but not all TLS code has this option
- AC_MSG_WARN([TLS/SSL implementation to use is OpenSSL but some code may still depend on NSS or GNUTLS])
- add_warning "TLS/SSL implementation to use is OpenSSL but some code may still depend on NSS or GNUTLS"
+ AC_MSG_WARN([TLS/SSL implementation to use is OpenSSL but some code may still depend on NSS])
+ add_warning "TLS/SSL implementation to use is OpenSSL but some code may still depend on NSS"
;;
nss)
AC_DEFINE(USE_TLS_NSS)
@@ -10949,25 +10949,6 @@ if test "$build_crypto" = yes; then
fi
dnl ===================================================================
-dnl Check for building gnutls
-dnl ===================================================================
-AC_MSG_CHECKING([whether to use gnutls])
-if test "$WITH_WEBDAV" = "neon" -a "$with_system_neon" = no -a "$enable_openssl" = "no"; then
- AC_MSG_RESULT([yes])
- AM_PATH_LIBGCRYPT()
- PKG_CHECK_MODULES(GNUTLS, [gnutls],,
- AC_MSG_ERROR([[Disabling OpenSSL was requested, but GNUTLS is not
- available in the system to use as replacement.]]))
- FilterLibs "${LIBGCRYPT_LIBS}"
- LIBGCRYPT_LIBS="${filteredlibs}"
-else
- AC_MSG_RESULT([no])
-fi
-
-AC_SUBST([LIBGCRYPT_CFLAGS])
-AC_SUBST([LIBGCRYPT_LIBS])
-
-dnl ===================================================================
dnl Check for system redland
dnl ===================================================================
dnl redland: versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)