summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2023-11-16 14:28:55 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2023-11-16 23:32:20 +0100
commite514f1a462f5fe2d1ef2d58fa3a0ef94892c41fb (patch)
tree42a56eb53cd74a522de6d2d65e8cb1a863740101 /configure.ac
parentd343a2b6393aec2eba0d25d7f4f390f12d1515f6 (diff)
fix --enable-wix switch - that didn't do anything
it used the wrong variable name in AC_SUBST and also had no place where it would be set for the rest of the build to use. Also the script hardcodes the location of the WiX Toolkit, so check for the same path in configure. Also it was needlessly tied to LIBO_TEST_INSTALL - since it has its own conditional, "double-guarding" it is not necessary. Change-Id: I6dd4a41e63d2a43a3e2f1aac5b6799a6601eb656 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/159510 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5c78e2bd2f6d..d6a6bf43fd95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13680,12 +13680,14 @@ if test "$enable_wix" = "" -o "enable_wix" = "no"; then
ENABLE_WIX=
else
AC_MSG_RESULT([yes])
- if ! which candle >/dev/null 2>&1; then
- AC_MSG_ERROR([WiX requested but WiX toolset not found.])
+ # FIXME: this should do proper detection, but the path is currently
+ # hardcoded in msicreator/createmsi.py
+ if ! test -x "/cygdrive/c/Program Files (x86)/WiX Toolset v3.11/bin/candle"; then
+ AC_MSG_ERROR([WiX requested but WiX toolset v3.11 not found at the expected location])
fi
ENABLE_WIX=TRUE
fi
-AC_SUBST(ENABLE_SILENT_MSI)
+AC_SUBST(ENABLE_WIX)
AC_MSG_CHECKING([whether and how to use Xinerama])
if test "$USING_X11" = TRUE; then