summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Nabet <serval2412@yahoo.fr>2023-04-15 10:36:42 +0200
committerJulien Nabet <serval2412@yahoo.fr>2023-04-16 10:17:16 +0200
commite542aa8c3ac78fc0f36dd06d6fa8dc3d5b0ac588 (patch)
tree75fc04d20f36c822f6cb19779f8fb05d61a7e440 /configure.ac
parent1d12d12598927ef8a74dd648632112ceb16bdf78 (diff)
configure.ac: add error message if NET SDK not found
+ rename find_dotnetsdk46 to find_dotnetsdk Change-Id: I6354ed1a900bb3b86999bee4354f628e79318924 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/150440 Tested-by: Jenkins Reviewed-by: Taichi Haradaguchi <20001722@ymail.ne.jp> Reviewed-by: Julien Nabet <serval2412@yahoo.fr>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a7d04b853365..87c42a10f5cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6523,7 +6523,7 @@ find_al()
done
}
-find_dotnetsdk46()
+find_dotnetsdk()
{
unset frametest
@@ -6534,6 +6534,7 @@ find_dotnetsdk46()
return
fi
done
+ AC_MSG_ERROR([The Windows NET SDK (minimum 4.6) not found, check the installation])
}
find_winsdk_version()
@@ -6887,7 +6888,7 @@ if test "$build_os" = "cygwin" -o "$build_os" = "wsl"; then
dnl Check mscoree.lib / .NET Framework dir
AC_MSG_CHECKING(.NET Framework)
- find_dotnetsdk46
+ find_dotnetsdk
PathFormat "$frametest"
frametest="$formatted_path_unix"
if test -f "$frametest/Lib/um/$WIN_BUILD_ARCH/mscoree.lib"; then