summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noel.grandin@collabora.co.uk>2016-12-14 11:40:10 +0200
committerNoel Grandin <noel.grandin@collabora.co.uk>2016-12-14 11:41:15 +0200
commit38c3386549251a46e0659c179883ee4370dad63a (patch)
tree2de075b36e2c8f8945c0481e8000861781ba0486 /configure.ac
parentc826ddfc2c213ae61918793eefe0c6593ce9bb17 (diff)
disable -Og on clang for now
Change-Id: Ia8f8ab2e84e41d2767a566be4009ddc54e4f2890
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c26693be25c1..29a30d02bc20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3797,7 +3797,8 @@ if test "$GCC" = "yes"; then
CFLAGS="$CFLAGS -Werror -Og"
AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ HAVE_GCC_OG=TRUE ],[])
CFLAGS=$save_CFLAGS
- if test "$HAVE_GCC_OG" = "TRUE"; then
+ # clang as of version 4.0.0 (trunk 289424) doesn't do this very well (missing locals, bad param info in stack frame)
+ if test "$HAVE_GCC_OG" = "TRUE" -a "$COM_IS_CLANG" != "TRUE"; then
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])