summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2013-01-26 16:59:36 +0100
committerMichael Stahl <mstahl@redhat.com>2013-01-28 12:42:25 +0000
commit9cacd76701360e30cbee2ccee61a3722b19b4531 (patch)
tree41c0fc4c0efd5fea03271126b3926703648f5f46 /configure.ac
parent69bb1336bfbbc9fbdc08027490b0174c904eee0f (diff)
configure: accept building without themes
If --with-theme=no is specified disallow any check for valid themes which would otherwise give an error. Change-Id: I45d2872145f3bd15e17beac4f69f8b4b1855d9a3 Reviewed-on: https://gerrit.libreoffice.org/1879 Tested-by: LibreOffice gerrit bot <gerrit@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index dc13c159b07d..7a29b481f11c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10824,14 +10824,16 @@ if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
fi
WITH_THEMES=""
-for theme in $with_theme; do
- case $theme in
- crystal|default|galaxy|hicontrast|human|industrial|oxygen|tango|tango_testing) : ;;
- *) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
- esac
- WITH_THEMES="$WITH_THEMES $theme"
- SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[[:lower:]]' '[[:upper:]]'`"
-done
+if test "x$with_theme" != "xno"; then
+ for theme in $with_theme; do
+ case $theme in
+ crystal|default|galaxy|hicontrast|human|industrial|oxygen|tango|tango_testing) : ;;
+ *) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
+ esac
+ WITH_THEMES="$WITH_THEMES $theme"
+ SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[[:lower:]]' '[[:upper:]]'`"
+ done
+fi
AC_MSG_RESULT([$WITH_THEMES])
AC_SUBST([WITH_THEMES])