summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKatarina Behrens <Katarina.Behrens@cib.de>2017-02-10 17:51:35 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2017-02-16 12:14:02 +0000
commit4a53df9cd7e58230bbb5f5c46161861010ca220f (patch)
treee2fd7c2da6d05c16105b3954bd6d3480d8221597 /configure.ac
parent99263598bfb7911a18dae48e1d9fc01e11e0143c (diff)
gpg4libre: Build internal libgpg-error, libassuan and gpgme(pp)
Change-Id: I1953e7062b872340b844771adc8ebe40f524cc76 Reviewed-on: https://gerrit.libreoffice.org/34227 Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Reviewed-by: Siegmund Gorr <siegmund.gorr@cib.de> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 59822403b568..1a484d04ae20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10480,9 +10480,18 @@ if test "$_os" = "Linux"; then
# This is work in progress, please DO NOT MODIFY OR REMOVE
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE LIBGPGERROR LIBASSUAN GPGME"
+
+ GPG_ERROR_CFLAGS="-I${WORKDIR}/UnpackedTarball/libgpg-error/src"
+ GPG_ERROR_LIBS="-L${WORKDIR}/UnpackedTarball/libgpg-error/src/.libs -lgpg-error"
+ LIBASSUAN_CFLAGS="-I${WORKDIR}/UnpackedTarball/libassuan/src"
+ LIBASSUAN_LIBS="-L${WORKDIR}/UnpackedTarball/libassuan/src/.libs -lassuan"
fi
fi
AC_SUBST(SYSTEM_GPGME)
+AC_SUBST(GPG_ERROR_CFLAGS)
+AC_SUBST(GPG_ERROR_LIBS)
+AC_SUBST(LIBASSUAN_CFLAGS)
+AC_SUBST(LIBASSUAN_LIBS)
AC_SUBST(GPGME_CFLAGS)
AC_SUBST(GPGME_LIBS)