summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-09-19 22:06:10 +0300
committerTor Lillqvist <tml@collabora.com>2017-09-19 22:06:48 +0300
commitd00110cf5589f04f198742a1ee6d7f43aebe3c0b (patch)
tree9dbf46312592eca6d83b7a2ae71596f98712cc31 /configure.ac
parent7c8db524248bacc1dfa22df7bad0ad81e31d63ca (diff)
Accept macOS 10.13
Change-Id: I52fb11c8830a5a78c7a9181708f1727b473069e3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 08a30cdd0352..fb4f406ef02d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2622,7 +2622,7 @@ if test $_os = Darwin -o $_os = iOS; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in $with_macosx_sdk 10.9 10.10 10.11 10.12; do
+ for _macosx_sdk in $with_macosx_sdk 10.9 10.10 10.11 10.12 10.13; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2663,8 +2663,11 @@ if test $_os = Darwin -o $_os = iOS; then
10.12)
MACOSX_SDK_VERSION=101200
;;
+ 10.13)
+ MACOSX_SDK_VERSION=101300
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.9--12])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.9--13])
;;
esac
@@ -2696,8 +2699,11 @@ if test $_os = Darwin -o $_os = iOS; then
10.12)
MAC_OS_X_VERSION_MIN_REQUIRED="101200"
;;
+ 10.13)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.9--12])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.9--13])
;;
esac
@@ -2733,8 +2739,11 @@ if test $_os = Darwin -o $_os = iOS; then
10.12)
MAC_OS_X_VERSION_MAX_ALLOWED="101200"
;;
+ 10.13)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.9--12])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.9--13])
;;
esac