summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2017-12-01 12:00:35 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-12-04 09:07:57 +0100
commitd4246aeaa2b182c3defcefb68426d1be8e2caf75 (patch)
tree802bbb83df5f4939ec30e117efb60c0d0c8e6472 /configure.ac
parent19339e79e41cb9bbbbf0bd9a0e0d4a2cccc1f6a5 (diff)
EPUB export, fixed layout: fix spine names
They are pages, not sections. Change-Id: Ifd72d5ebec1d372a9bd99653d849479a6ffb6bfa Reviewed-on: https://gerrit.libreoffice.org/45690 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8c5434bd1883..264e4ba99750 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7688,7 +7688,8 @@ AS_IF([test "$SYSTEM_EPUBGEN" = "TRUE"], [
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
#include <libepubgen/libepubgen.h>
], [
- const libepubgen::EPUBTextGenerator generator(nullptr, EPUB_SPLIT_METHOD_NONE, 30);
+ libepubgen::EPUBTextGenerator generator(nullptr);
+ generator.setOption(libepubgen::EPUB_GENERATOR_OPTION_SPLIT, libepubgen::EPUB_SPLIT_METHOD_NONE);
])],
[
AC_MSG_RESULT([yes])