summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-11-01 12:17:32 +0100
committerMichael Stahl <mstahl@redhat.com>2013-11-04 21:52:08 +0100
commit133d59adf744b2279a7d59071ca834ac766b9719 (patch)
tree2b49cfacc90cc230411da5611dd7ff7e2f26cb89 /configure.ac
parent2ff7b04c1b205b14dc1bace1e90ee62d26db9643 (diff)
configure: build oox with NSS backend by default
Because NSS libraries are dynamic and OpenSSL static, using NSS saves 1.5 MB in the oox library [even though it's not as 1337 apparently]: -rwxrwxr-x. 1 ms ms 8889575 2. Nov 13:45 libooxlo.so.nss -rwxrwxr-x. 1 ms ms 7773576 2. Nov 13:45 libooxlo.so.nss.stripped -rwxrwxr-x. 1 ms ms 10340276 2. Nov 13:37 libooxlo.so.openssl -rwxrwxr-x. 1 ms ms 9042216 2. Nov 13:37 libooxlo.so.openssl.stripped Change-Id: I387496ae364acb1286d753d52f04924631136750
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 99209b6af457..1c569aff7719 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8785,13 +8785,9 @@ nss - Mozilla's Network Security Services (NSS)
;;
esac
else
- if test "$enable_openssl" = "yes"; then
- AC_DEFINE(USE_TLS_OPENSSL)
- TLS=OPENSSL
- else
- AC_DEFINE(USE_TLS_NSS)
- TLS=NSS
- fi
+ # default to using NSS, it results in smaller oox lib
+ AC_DEFINE(USE_TLS_NSS)
+ TLS=NSS
fi
AC_MSG_RESULT([$TLS])
AC_SUBST(TLS)