summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVasily Melenchuk <vasily.melenchuk@cib.de>2018-07-18 02:00:18 +0300
committerNoel Grandin <noel.grandin@collabora.co.uk>2018-07-18 10:44:12 +0200
commit13d0b53fe4030f0be7bd176a2934548f57bff729 (patch)
tree05c43de9555b26e7a2ed551b101b34b87d61974a /configure.ac
parent0bc495a56203863b332ea6bb43172786195a1724 (diff)
configure: diagnose and report cygpath convert failure
If Windows machine has short filenames disabled, it is not reported during configure run, but leads to unexpected and difficult to understand failures later. Checking of cygpath call conversion result should help to diagnose this problem earlier. Change-Id: Ia93ae612f4bc624bc3e71c6733838fd14b075f64 Reviewed-on: https://gerrit.libreoffice.org/57608 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2fd11a9b3d19..7308d31faebd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,10 @@ PathFormat()
AC_MSG_ERROR([path conversion failed for "$1".])
fi
fi
+ fp_count_space=`echo "$formatted_path" | $GREP -c "[ ]"`
+ if test "$fp_count_space" != "0"; then
+ AC_MSG_ERROR([converted path "$formatted_path" still contains spaces. Short filenames (8.3 filenames) support was disabled on this system?])
+ fi
fi
}