summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2020-10-02 21:19:20 +0200
committerCaolán McNamara <caolanm@redhat.com>2020-10-04 14:57:43 +0200
commit20879693c6d1c384eafee610d5185a5a00c8ee68 (patch)
tree5cb718967a72aad627a657de09829d6a9a6644cb /configure.ac
parentbb66f3b772115506b8b39e6cc24c1f82e7a6dc1e (diff)
Replace "newlined" sed with tr
This doesn't filter the list on Windows Cygwin, resulting in a lot of wrong stuff in the BUILD_TYPE, which actually isn't build. Since the next line uses tr, use this here too. Regressed-by: d4105c8aec2e1815aa536c50bc742dd5c8bff940 Change-Id: I750bd1bd5084ff5a23b4635f3ee63f46ba1dd83f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/103871 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 08469ca830a5..a781b4ecd222 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5044,8 +5044,7 @@ if test "$cross_compiling" = "yes"; then
# converts BUILD_TYPE and PERMITTED_BUILD_TARGETS into non-whitespace,
# newlined lists, to use grep as a filter
PERMITTED_BUILD_TARGETS=$(echo "$PERMITTED_BUILD_TARGETS" | sed -e '/^ *$/d' -e 's/ *//')
- BUILD_TARGETS="$(sed -n -e '/^export BUILD_TYPE=/ s/.*=//p' config_host.mk | sed -e 's/ /\
-/')"
+ BUILD_TARGETS="$(sed -n -e '/^export BUILD_TYPE=/ s/.*=//p' config_host.mk | tr ' ' '\n')"
BUILD_TARGETS="$(echo "$BUILD_TARGETS" | grep -F "$PERMITTED_BUILD_TARGETS" | tr '\n' ' ')"
sed -i -e "s/ BUILD_TYPE=.*$/ BUILD_TYPE=$BUILD_TARGETS/" config_host.mk