summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-05-11 21:27:51 +0200
committerMichael Stahl <Michael.Stahl@cib.de>2019-05-12 09:35:08 +0200
commit2ae92ea44ceea43004f7d98cc6c767c8b16455ac (patch)
tree7e43498fcc8ee134212c10d4e991003538558839 /configure.ac
parent62d6d8cb1c58d8859c9ac2f65744b65558837f2a (diff)
configure: javac 1.8 does not have --add-exports
... hence it will print a pointless warning about some problem that doesn't affect JDK 8 anyway. Change-Id: Ic7669950dbb16815c85e4b8eb9d07d75c68d1b82 Reviewed-on: https://gerrit.libreoffice.org/72172 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a2b3c4c1b12..79416d79ecdb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7516,7 +7516,7 @@ if test -n "$ENABLE_JAVA" -a -z "$JAVAINC"; then
fi
SOLARINC="$SOLARINC $JAVAINC"
-if test "$ENABLE_JAVA" != "" -a "x" != "x$JAVACOMPILER"; then
+if test "$ENABLE_JAVA" != "" -a "x" != "x$JAVACOMPILER" -a "$_jdk_ver" -ge 10900; then
url_check_unknown=0
java_base="testurlcheck"
java_src="${java_base}.java"